Browser Phone, Conference Calling, and 4 other services are down
Resolved
Feb 12, 2026 at 7:58pm UTC
Lead Payments & Billing recovered.
Affected services
Updated
Feb 12, 2026 at 6:43pm UTC
Lead Payments & Billing is degraded.
Affected services
Updated
Feb 12, 2026 at 6:42pm UTC
Drip & Transactional Emails recovered.
Affected services
Updated
Feb 12, 2026 at 4:04pm UTC
SMS recovered.
Affected services
Updated
Feb 12, 2026 at 3:45pm UTC
Browser Phone and Conference Calling recovered.
Affected services
Updated
Feb 12, 2026 at 3:39pm UTC
Conference Calling is degraded.
Affected services
Updated
Feb 12, 2026 at 3:38pm UTC
Browser Phone is degraded.
Affected services
Updated
Feb 12, 2026 at 3:01pm UTC
SMS is degraded.
Affected services
Updated
Feb 12, 2026 at 8:04am UTC
SMS recovered.
Affected services
Updated
Feb 11, 2026 at 10:43pm UTC
SMS is degraded.
Affected services
Updated
Feb 11, 2026 at 9:01pm UTC
Call Recording recovered.
Affected services
Updated
Feb 11, 2026 at 8:54pm UTC
Call Recording is degraded.
Affected services
Updated
Feb 11, 2026 at 7:51pm UTC
Browser Phone recovered.
Affected services
Updated
Feb 11, 2026 at 7:45pm UTC
Browser Phone is degraded.
Affected services
Updated
Feb 11, 2026 at 6:49pm UTC
Drip & Transactional Emails is degraded.
Affected services
Updated
Feb 11, 2026 at 2:08am UTC
SMS recovered.
Affected services
Created
Feb 11, 2026 at 1:55am UTC
SMS is degraded.
Affected services