Back to overview
Degraded

Voice Services, Outbound Dialing, and 4 other services are down

Feb 15, 2026 at 8:16am UTC
Affected services
Voice Services
Outbound Dialing
Browser Phone
Conference Calling
Call Recording
SMS

Resolved
Feb 15, 2026 at 3:15pm UTC

Conference Calling recovered.

Updated
Feb 15, 2026 at 3:10pm UTC

Conference Calling is degraded.

Updated
Feb 15, 2026 at 2:28pm UTC

SMS recovered.

Updated
Feb 15, 2026 at 2:24pm UTC

Browser Phone recovered.

Updated
Feb 15, 2026 at 2:19pm UTC

Browser Phone is degraded.

Updated
Feb 15, 2026 at 2:17pm UTC

SMS is degraded.

Updated
Feb 15, 2026 at 2:05pm UTC

Browser Phone recovered.

Updated
Feb 15, 2026 at 2:03pm UTC

Conference Calling recovered.

Updated
Feb 15, 2026 at 1:58pm UTC

Browser Phone and Conference Calling are degraded.

Updated
Feb 15, 2026 at 12:44pm UTC

Voice Services recovered.

Updated
Feb 15, 2026 at 12:43pm UTC

SMS recovered.

Updated
Feb 15, 2026 at 12:42pm UTC

Call Recording recovered.

Updated
Feb 15, 2026 at 12:42pm UTC

Browser Phone and Conference Calling recovered.

Updated
Feb 15, 2026 at 12:42pm UTC

Outbound Dialing recovered.

Updated
Feb 15, 2026 at 12:37pm UTC

Call Recording is degraded.

Updated
Feb 15, 2026 at 12:33pm UTC

Browser Phone and Conference Calling are degraded.

Updated
Feb 15, 2026 at 12:32pm UTC

Outbound Dialing is degraded.

Updated
Feb 15, 2026 at 12:31pm UTC

Voice Services is degraded.

Updated
Feb 15, 2026 at 12:31pm UTC

SMS is degraded.

Updated
Feb 15, 2026 at 11:37am UTC

SMS recovered.

Created
Feb 15, 2026 at 8:16am UTC

SMS is degraded.