Back to overview
Degraded

Voice Services, SMS, and 2 other services are down

Mar 18, 2026 at 5:04am UTC
Affected services
Voice Services
SMS
Drip & Transactional Emails
Lead Payments & Billing

Resolved
Mar 19, 2026 at 3:47pm UTC

Voice Services recovered.

Updated
Mar 19, 2026 at 3:42pm UTC

Voice Services is degraded.

Updated
Mar 19, 2026 at 2:22pm UTC

Lead Payments & Billing recovered.

Updated
Mar 19, 2026 at 12:22pm UTC

Lead Payments & Billing is degraded.

Updated
Mar 19, 2026 at 10:22am UTC

SMS recovered.

Updated
Mar 19, 2026 at 10:16am UTC

SMS is degraded.

Updated
Mar 19, 2026 at 7:04am UTC

SMS recovered.

Updated
Mar 19, 2026 at 3:01am UTC

SMS is degraded.

Updated
Mar 19, 2026 at 2:04am UTC

Drip & Transactional Emails recovered.

Updated
Mar 18, 2026 at 6:34pm UTC

Drip & Transactional Emails is degraded.

Updated
Mar 18, 2026 at 7:07am UTC

SMS recovered.

Created
Mar 18, 2026 at 5:04am UTC

SMS is degraded.