Back to overview
Degraded

Voice Services, Outbound Dialing, and 4 other services are down

Mar 20, 2026 at 2:16am UTC
Affected services
Voice Services
Outbound Dialing
Browser Phone
Conference Calling
Call Recording
SMS

Resolved
Mar 20, 2026 at 11:41pm UTC

Voice Services recovered.

Updated
Mar 20, 2026 at 11:35pm UTC

Voice Services is degraded.

Updated
Mar 20, 2026 at 1:11pm UTC

Outbound Dialing recovered.

Updated
Mar 20, 2026 at 1:11pm UTC

Voice Services recovered.

Updated
Mar 20, 2026 at 1:06pm UTC

Browser Phone and Conference Calling recovered.

Updated
Mar 20, 2026 at 1:05pm UTC

Voice Services is degraded.

Updated
Mar 20, 2026 at 1:00pm UTC

Conference Calling is degraded.

Updated
Mar 20, 2026 at 1:00pm UTC

Browser Phone is degraded.

Updated
Mar 20, 2026 at 12:57pm UTC

Outbound Dialing is degraded.

Updated
Mar 20, 2026 at 11:04am UTC

SMS recovered.

Updated
Mar 20, 2026 at 10:29am UTC

Voice Services recovered.

Updated
Mar 20, 2026 at 10:27am UTC

Browser Phone and Conference Calling recovered.

Updated
Mar 20, 2026 at 10:21am UTC

Conference Calling is degraded.

Updated
Mar 20, 2026 at 10:21am UTC

Voice Services is degraded.

Updated
Mar 20, 2026 at 10:20am UTC

Outbound Dialing recovered.

Updated
Mar 20, 2026 at 10:15am UTC

Outbound Dialing and Browser Phone are degraded.

Updated
Mar 20, 2026 at 7:05am UTC

Voice Services recovered.

Updated
Mar 20, 2026 at 7:03am UTC

Conference Calling recovered.

Updated
Mar 20, 2026 at 7:00am UTC

Voice Services is degraded.

Updated
Mar 20, 2026 at 6:53am UTC

Outbound Dialing recovered.

Updated
Mar 20, 2026 at 6:49am UTC

Conference Calling is degraded.

Updated
Mar 20, 2026 at 6:48am UTC

Outbound Dialing is degraded.

Updated
Mar 20, 2026 at 3:01am UTC

SMS is degraded.

Updated
Mar 20, 2026 at 2:21am UTC

Call Recording recovered.

Created
Mar 20, 2026 at 2:16am UTC

Call Recording is degraded.