Voice Services, Outbound Dialing, and 6 other services are down
Resolved
Apr 9, 2026 at 7:38am UTC
Outbound Dialing recovered.
Affected services
Updated
Apr 9, 2026 at 7:38am UTC
Voice Services recovered.
Affected services
Updated
Apr 9, 2026 at 7:37am UTC
SMS and Lead Payments & Billing recovered.
Affected services
Updated
Apr 9, 2026 at 7:37am UTC
Call Recording and Drip & Transactional Emails recovered.
Affected services
Updated
Apr 9, 2026 at 7:36am UTC
Browser Phone and Conference Calling recovered.
Affected services
Updated
Apr 9, 2026 at 7:22am UTC
Drip & Transactional Emails is degraded.
Affected services
Updated
Apr 9, 2026 at 7:05am UTC
Lead Payments & Billing is degraded.
Affected services
Updated
Apr 9, 2026 at 6:50am UTC
Outbound Dialing is degraded.
Affected services
Updated
Apr 9, 2026 at 6:50am UTC
Voice Services is degraded.
Affected services
Updated
Apr 9, 2026 at 6:48am UTC
Browser Phone, Conference Calling, and Call Recording are degraded.
Affected services
Created
Apr 9, 2026 at 3:01am UTC
SMS is degraded.
Affected services