Back to overview
Degraded
SMS and Drip & Transactional Emails are down
Apr 11, 2026 at 11:03am UTC
Affected services
SMS
Drip & Transactional Emails
Resolved
Apr 13, 2026 at 3:34pm UTC
Drip & Transactional Emails recovered.
Affected services
Updated
Apr 13, 2026 at 12:04pm UTC
SMS recovered.
Affected services
Updated
Apr 13, 2026 at 3:01am UTC
SMS is degraded.
Affected services
Updated
Apr 11, 2026 at 11:01pm UTC
Drip & Transactional Emails is degraded.
Affected services
Updated
Apr 11, 2026 at 3:04pm UTC
Drip & Transactional Emails recovered.
Affected services
Created
Apr 11, 2026 at 11:03am UTC
Drip & Transactional Emails is degraded.
Affected services