Back to overview
Degraded

SMS and Lead Payments & Billing are down

Apr 14, 2026 at 3:04am UTC
Affected services
SMS
Lead Payments & Billing

Resolved
Apr 15, 2026 at 9:04am UTC

SMS recovered.

Updated
Apr 15, 2026 at 5:01am UTC

SMS is degraded.

Updated
Apr 15, 2026 at 12:52am UTC

Lead Payments & Billing recovered.

Updated
Apr 14, 2026 at 5:22pm UTC

Lead Payments & Billing is degraded.

Updated
Apr 14, 2026 at 12:04pm UTC

SMS recovered.

Updated
Apr 14, 2026 at 11:13am UTC

Lead Payments & Billing recovered.

Updated
Apr 14, 2026 at 10:16am UTC

Lead Payments & Billing is degraded.

Updated
Apr 14, 2026 at 9:46am UTC

Lead Payments & Billing recovered.

Updated
Apr 14, 2026 at 8:40am UTC

Lead Payments & Billing is degraded.

Created
Apr 14, 2026 at 3:04am UTC

SMS is degraded.