Back to overview
Degraded

SMS and Lead Payments & Billing are down

Apr 18, 2026 at 2:01am UTC
Affected services
SMS
Lead Payments & Billing

Resolved
Apr 18, 2026 at 6:52am UTC

Lead Payments & Billing recovered.

Updated
Apr 18, 2026 at 6:49am UTC

SMS recovered.

Updated
Apr 18, 2026 at 3:49am UTC

Lead Payments & Billing is degraded.

Created
Apr 18, 2026 at 2:01am UTC

SMS is degraded.