Back to overview
Degraded

Voice Services, SMS, and 1 other service are down

May 8, 2026 at 2:55am UTC
Affected services
Voice Services
SMS
Lead Payments & Billing

Resolved
May 8, 2026 at 2:55pm UTC

Lead Payments & Billing recovered.

Updated
May 8, 2026 at 2:10pm UTC

Lead Payments & Billing is degraded.

Updated
May 8, 2026 at 8:04am UTC

SMS recovered.

Updated
May 8, 2026 at 5:17am UTC

Voice Services recovered.

Updated
May 8, 2026 at 3:05am UTC

SMS is degraded.

Created
May 8, 2026 at 2:55am UTC

Voice Services is degraded.