Back to overview
Degraded

Voice Services, Outbound Dialing, and 2 other services are down

May 9, 2026 at 4:02am UTC
Affected services
Voice Services
Outbound Dialing
Browser Phone
Conference Calling

Resolved
May 9, 2026 at 12:27pm UTC

Browser Phone and Conference Calling recovered.

Updated
May 9, 2026 at 12:26pm UTC

Outbound Dialing recovered.

Updated
May 9, 2026 at 12:26pm UTC

Voice Services recovered.

Updated
May 9, 2026 at 4:03am UTC

Browser Phone and Conference Calling are degraded.

Updated
May 9, 2026 at 4:02am UTC

Outbound Dialing is degraded.

Created
May 9, 2026 at 4:02am UTC

Voice Services is degraded.