Back to overview
Resolved

Voice Services, Outbound Dialing, and 4 other services are down

Jun 23, 2026 at 3:01am UTC
Affected services
Voice Services
Outbound Dialing
Browser Phone
Conference Calling
Call Recording
SMS

Resolved
Jun 23, 2026 at 2:49pm UTC

Call Recording recovered.

Updated
Jun 23, 2026 at 2:48pm UTC

Browser Phone recovered.

Updated
Jun 23, 2026 at 2:48pm UTC

Outbound Dialing and Conference Calling recovered.

Updated
Jun 23, 2026 at 2:48pm UTC

Voice Services recovered.

Updated
Jun 23, 2026 at 2:47pm UTC

SMS recovered.

Updated
Jun 23, 2026 at 2:25pm UTC

Browser Phone and Conference Calling are degraded.

Updated
Jun 23, 2026 at 2:24pm UTC

Voice Services and Outbound Dialing are degraded.

Updated
Jun 23, 2026 at 2:22pm UTC

Call Recording and SMS are degraded.

Updated
Jun 23, 2026 at 5:04am UTC

SMS recovered.

Created
Jun 23, 2026 at 3:01am UTC

SMS is degraded.