Back to overview
Resolved

Voice Services, Conference Calling, and 1 other service are down

Jul 13, 2026 at 1:33pm UTC
Affected services
Voice Services
Conference Calling
SMS

Resolved
Jul 13, 2026 at 10:58pm UTC

SMS recovered.

Updated
Jul 13, 2026 at 8:19pm UTC

SMS is degraded.

Updated
Jul 13, 2026 at 7:25pm UTC

SMS recovered.

Updated
Jul 13, 2026 at 3:40pm UTC

SMS is degraded.

Updated
Jul 13, 2026 at 2:48pm UTC

Conference Calling recovered.

Updated
Jul 13, 2026 at 2:47pm UTC

Voice Services recovered.

Updated
Jul 13, 2026 at 1:35pm UTC

Voice Services is degraded.

Created
Jul 13, 2026 at 1:33pm UTC

Conference Calling is degraded.