Back to overview
Resolved

SMS and Lead Payments & Billing are down

Jul 20, 2026 at 2:01am UTC
Affected services
SMS
Lead Payments & Billing

Resolved
Jul 20, 2026 at 10:37pm UTC

Lead Payments & Billing recovered.

Updated
Jul 20, 2026 at 9:43pm UTC

Lead Payments & Billing is degraded.

Updated
Jul 20, 2026 at 12:04pm UTC

SMS recovered.

Created
Jul 20, 2026 at 2:01am UTC

SMS is degraded.