Back to overview
Resolved

Voice Services, Outbound Dialing, and 3 other services are down

Jul 23, 2026 at 3:01am UTC
Affected services
Voice Services
Outbound Dialing
SMS
Drip & Transactional Emails
Lead Payments & Billing

Resolved
Jul 24, 2026 at 7:37pm UTC

Drip & Transactional Emails recovered.

Updated
Jul 24, 2026 at 12:20pm UTC

Lead Payments & Billing recovered.

Updated
Jul 24, 2026 at 12:04pm UTC

SMS recovered.

Updated
Jul 24, 2026 at 12:02pm UTC

Lead Payments & Billing is degraded.

Updated
Jul 24, 2026 at 3:31am UTC

SMS is degraded.

Updated
Jul 24, 2026 at 2:07am UTC

Drip & Transactional Emails is degraded.

Updated
Jul 24, 2026 at 1:05am UTC

Outbound Dialing recovered.

Updated
Jul 24, 2026 at 1:05am UTC

Voice Services recovered.

Updated
Jul 23, 2026 at 11:02pm UTC

Outbound Dialing is degraded.

Updated
Jul 23, 2026 at 11:02pm UTC

Voice Services is degraded.

Updated
Jul 23, 2026 at 7:04am UTC

SMS recovered.

Created
Jul 23, 2026 at 3:01am UTC

SMS is degraded.